JSN Power Customization Manual
Before We Start
The first thing we would like to say is this guide is not intended to cover everything you might want to customize the template.
Here we disclose only the most frequently asked customization questions and how to change the demo content in the sample
data by your own data. We hope you can find the answer to your question here and satisfied with it.

JSN PowerAdmin
JSN PowerAdmin is a powerful tool that helps Joomla users enjoy Joomla with ease. This recommended tool is not only for
Joomla newbies but also advanced users. It gets “popular badge” on JED and receives positive feedback from Joomla
community. This extension is included when you install full sample data. You can download it for free here if you just install
the layout and style of the template: Download JSN PowerAdmin For Free. (https://www.joomlashine.com/joomlaextensions/jsn-poweradmin.html)

JSN PageBuilder 3
JSN PageBuilder 3 is built as a native Joomla! editor plugin. Therefore, it works perfectly on Joomla! articles, Custom HTML
modules, and even third-party extensions. Besides editing articles in the backend, JSN PageBuilder 3 also enables you to edit
your articles directly on the frontend thanks to the native Joomla! frontend editing mechanism. By using JSN PageBuilder 3,
you can build complex Joomla! pages in minutes with no coding skills required. The FREE Edition of this extension is included
when you install the sample data. You can download it for free here if you just install the layout and style of the template:
Download JSN PageBuilder 3 For Free. (https://www.joomlashine.com/joomla-extensions/jsn-pagebuilder.html)

Favicon
Favicon is a small icon positioned on the left of the address bar of your browser. By default, Joomla! has an icon as shown on
the screenshot below.

Favicon presentation

Here are instructions on how to do that:

Step 1: Create Favicon File
Favicon is a regular 16px * 16px icon file with exact name favicon.ico. In most cases, favicon is the sized-down version of the
company logo saved in the icon format. In some cases, the logo is too specific and favicon needs to be built from scratch.
You can use some professional icon editor software like Axialis IconWorkshop (http://www.axialis.com/)and Iconcool Editor
(http://www.iconcool.com/icon-editor.htm)or to use online favicon generators. (http://www.google.com/search?
q=favicon%2Bgenerator&amp;ie=utf-8&amp;oe=utf-8&amp;aq=t&amp;rls=org.mozilla%3AenGB%3Aofficial&amp;client=firefox-a)The first method gives you better quality, but takes more effort. The second method is
easier, but the quality is not the best.

Step 2: Upload Favicon File
After you have got the favicon file, it is time to upload it to your server. You will need to upload the icon file to the template
folder via FTP.
Let’s go to joomla_root_folder/images to create a new folder and upload the favicon file there.

Upload favicon file

Step 3: Change the favicon in the template settings
Go to Extensions → Templates → Styles → Template_Full_Name - Default → System tab → Icons → choose browse file in the
Favicon parameter, here you need to select favicon.ico updated before, and then click on Save System to finish.

Favicon selection

Media selector is opened. Now, select your uploaded favicon file to change.

Select favicon file via media selector

Power
The layout structure of Power homepage is configured with several sections, built entirely by JSN Sun Framework and divided
into 8 main sections as below.

Power Homepage presentation

Power Homepage contains:
1. Section: Header
2. Section: Promo
3. Section: Content Top
4. Section: Content Top Below
5. Section: Component
6. Section: Content Bottom
7. Section: Bottom
8. Section: Footer
NOTE: As the JSN Power - Default is assigning to all pages so we will edit it from here: Extensions → Templates → Styles →
JSN Power - Default.
If you choose the Blue color as default, for example, please edit here: Extensions → Templates → Styles → JSN Power - Blue.

JSN Power - Default style

Now, let’s explore what we can edit in the homepage.

Section: Header

“Header” section presentation

Go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Header section.

“Header” section configuration

Now, let's go to each item:

1. Logo

“Logo” item configuration

This logo item is created directly in JSN Sun Framework’s Layout Manager. To config, click on logo item and make necessary
changes to related settings on the right panel.
Here you can change the Logo link on the desktop and mobile, Logo Alt, Text, Logo Link.

2. Menu
By default menu of JSN Power is Main Menu, you can change the menu by your own menu. Select the menu from your premade menus in the list to make it your site’s main menu.

“Menu” item configuration

Enable sticky menu
Your website will show a menu being sticky when the users scroll down the page.

Sticky menu configuration

To enable sticky menu you go to template layout, click on the “Mainmenu” Section and tick on the checkbox Enable Sticky.

Section: Promo

“Promo” section presentation

To edit Promo section, go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Promo.

“Promo” section configuration

Module Position: promo
Click on View Modules to check modules are assigned for this position.

Modules show on “Promo” position

1. “Homepage Slide” Module

“Homepage Slide” module

This is JSN ImageShow module with some configurations:
Module Class Suffix: jsn_promoslider
Showlist: Promo Slider
Showcase: Promo Slider
Overall Height: 600px
Please refer to JSN Imageshow Documentation (https://www.joomlashine.com/documentation/jsn-extensions/jsnimageshow/jsn-imageshow-configuration-manual.html) to see how to change the Showcase and Showlist.

2. “Our Subjects” Module

“Our Subjects” module

This module is created by JSN PageBuilder 3 Free Edition with Image With Text element.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.
Click on each Block → Advanced tab → Attributes → Class: hover-bg cyan

Section: Content Top

“Content Top” section presentation

Go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Content Top section.

“Content Top” section configuration

Module Position: content-top
Click on View Modules → search Our Trainers to edit the contents.

“Our Trainers” module

This module is created by JSN PageBuilder 3 Free Edition with Image With Text element.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.
Click on each Block → Advanced tab → Attributes → Class: hover-block

Section: Content Top Below

“Content Top Below” section presentation

Go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Content Top Below section.

“Content Top Below” section configuration

Module Position: content-top-below
Click on View Modules to check modules are assigned for this position.

Modules show on “Content Top Below” position

1. “Why Choose Us” Module

“Why Choose Us” module

This module is created by JSN PageBuilder 3 Free Edition with some elements:
1. Heading Element
2. Media Element → Youtube
3. Heading Element
4. Paragraph Element
5. Button Element → Advanced tab → Attributes → Class: btn btn-primary bg-main-color
6. Section's Background: Go to Section → Styling tab → Background → Image to change the section's background.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.

2. “Count Up Numbers” Module

“Count Up Numbers” module

This module is created by JSN PageBuilder 3 Free Edition with Image With Text element.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.
1. Heading Element → Advanced tab → Attributes → Class: main-color counterUp
2. Image With Text Element → Advanced tab → Attributes → Class: border-main-color

Section: Component

“Component” section presentation

The layoutthe for Component section has 4 columns, only one of them is used on the homepage is Main Body item.

“Component” section configuration

The main body of JSN Power is single articles with the menu Home, you can change them by feature articles item or other
menu item type.

“Home” menu item configuration

Click on Edit button or go to Articles Manager → search Homepage to edit the contents.

“Homepage” article

This article is created by JSN PageBuilder 3 Free Edition with some elements:
1. Heading Element
2. Module Element: Our Products (ID 321)
3. Joomla Articles Module → General → Categories: Demo Content
4. Module Element: Recent Post (ID 306)
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this article.
Click on Article List → Advanced tab → Attributes → Class: artclies-1st-list
Click on Article List → Feature Image → Advanced tab → Attributes → Class: hover-image
Click on Article List → Title → Advanced tab → Attributes → Class: hover-main-color
To edit the module is called on Homepage module, go to Modules Manager → search Our Products module and Recent Post
module.

1. “Our Products” Module

“Our Products” module

This is J2Store Products display with the category is Products.

2. “Recent Post” Module

“Recent Post” module

This is Articles - Category module, you need to check some configurations on the Advanced tab.
Module Class Suffix: “ articles-list”
Module Style: richbox_1

Section: Content Bottom

“Content Bottom” section presentation

Go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Content Bottom section.

“Content Bottom” section configuration

Module Position: content-bottom
Click on View Modules to check modules are assigned for this position.

Modules show on “Content Bottom“ position

1. “Testimonial & Newsletter” Module

“Testimonial & Newsletter” module

This module is created by JSN PageBuilder 3 Free Edition with some elements:
1. Image Element
2. Heading Element
3. Paragraph Element
4. Subscribe form Element → Click on the Column → Advanced tab → Attributes → Class: bg-main-color
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.

2. “Do you like JSNPower?” Module

“Do you like JSNPower?” module

This module is created by JSN PageBuilder 3 Free Edition with some elements:
1. Section's Background: Go to Section → Styling tab → Background → Image to change the section's background.
2. Heading Element
3. Paragraph Element
4. Button Element → Advanced tab → Attributes → Class: btn btn-primary bg-main-color

You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.

Section: Bottom

“Bottom” section presentation

The Bottom section contains:
1. Layout Item: Logo
2. Module Position: Bottom 1
3. Module Position: Bottom 2
4. Module Position: Bottom 3
5. Module Position: Bottom 4
6. Module Position: Bottom 5
Go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Bottom section.

“Bottom” section configuration

1. Logo

“Logo” item configuration

“Logo” item configuration

This logo item is created directly in JSN Sun Framework’s Layout Manager. To config, click on logo item and make necessary
changes to related settings on the right panel.
Here you can change the Logo link on the desktop and mobile, Logo Alt, Text, Logo Link.

2. “Bottom 1” Module Position

“Bottom 1” module position configuration

Module Position: bottom-1
Click on View Modules → search Module Footer 1 to edit the contents.

“Module Footer 1” module

This module is created by JSN PageBuilder 3 Free Edition with some elements:
1. Paragraph Element
2. Icon Element
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.

3. Menu Module
JSN Power includes four modules are the same type, here we introduce a module for example.

“Bottom 2” module position configuration

Module Position: bottom-2
Click on View Modules → search Pages to edit the contents.

Click on View Modules → search Pages to edit the contents.

“Pages” module

This is a menu module with some configurations:
Menu: Main Menu
Base Item: Pages
Module Class Suffix: footer-module-menu
Header Class: title_line
With other module positions on the Bottom section you can check the name of the module is called:
Bottom 3: Extensions
Bottom 4: Features
Bottom 5: Joomla!

Section: Footer

“Footer” section presentation

To edit Footer section, go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Footer section.

“Footer” section configuration

Module Position: footer
Click View Modules → search Footer module.

“Footer” module

This module is a custom module, you can replace the default code to your own code by using CodeMirror or TinyMCE editor.

Sticky Position
JSN Power includes six sticky positions on the top, middle and bottom sections.

“Sticky” positions presentation

To setting for this sections, you can go to template settings page click on each position: Stick-lefttop, stick-righttop, stickleftmiddle, stick-rightmiddle, stick-leftbottom or stick-rightbottom, and then click on View Modules button on the page setting
on the right to see the module was assigned for that position.

Sticky positions configuration

The image below shows all the sticky positions. You can replace them to your content by using CodeMirror or TinyMCE editor.

Module the sticky positions

Go To Top
To turn on/off the Go To Top button, click on the layout of the entire page → Show “Go To Top” button.

“Go To Top” configuration

Fitness
The layout structure of Fitness homepage is configured with several sections, built entirely by JSN Sun Framework and divided
into 8 main sections as below.

Fitness Homepage presentation

Fitness Homepage contains:
1. Section: Header

1. Section: Header
2. Section: Promo
3. Section: Content Top
4. Section: Content Top Below
5. Section: Component
6. Section: Content Bottom
7. Section: Bottom
8. Section: Footer
The configuration of Fitness niche is the same with Power niche. Therefore, this documentation only focuses on special
sections that only available in Fitness niche.
Now, let’s explore what we can edit in the homepage.
Section: Promo

“Promo” section presentation

To edit Promo section, go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Promo.

“Promo” section configuration

Module Position: promo
Click on View Modules to check modules are assigned for this position.

Modules show on “Promo” position

1. “Homepage Slide” Module

“Homepage Slide” module

This is JSN ImageShow module with some configurations:
Module Class Suffix: jsn_promoslider
Showlist: Fitness Slider
Showcase: Promo Slider
Overall Height: 600px
Please refer to JSN Imageshow Documentation (https://www.joomlashine.com/documentation/jsn-extensions/jsnimageshow/jsn-imageshow-configuration-manual.html) to see how to change the Showcase and Showlist.

“Our Subjects” Module

“Our Subjects” module

This module is created by JSN PageBuilder 3 Free Edition with Image With Text element.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.
Click on each Block → Advanced tab → Attributes → Class: hover-bg cyan
Section: Bottom

“Bottom” section presentation

The Bottom section contains:
1. Layout Item: Logo
2. Module Position: Bottom 1
3. Module Position: Bottom 2
4. Module Position: Bottom 3
5. Module Position: Bottom 4
6. Module Position: Bottom 5

6. Module Position: Bottom 5
Go to Extensions → Templates → Styles → JSN Power - Default → Layout tab → Bottom section.

“Bottom” section configuration

1. Logo

“Logo” item configuration

This logo item is created directly in JSN Sun Framework’s Layout Manager. To config, click on logo item and make necessary
changes to related settings on the right panel.
Here you can change the Logo link on the desktop and mobile, Logo Alt, Text, Logo Link.

2. “Bottom 1” Module Position

“Bottom 1” module position configuration

Module Position: bottom-1

Click on View Modules → search Module Footer 1 to edit the contents.

“Module Footer 1” module

This module is created by JSN PageBuilder 3 Free Edition with some elements:
1. Paragraph Element
2. Icon Element
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.

3. Menu Module
JSN Power include two modules are the same type, here we introduce a module for example.

“Bottom 2” module position configuration

Module Position: bottom-2
Click on View Modules → search About to edit the contents.

“Pages” module

This is a menu module with some configurations:
Menu: Main Menu
Module Class Suffix: footer-module-menu
Header Class: title_line
With other module positions on the Bottom section you can check the name of the module is called:
Bottom 3: Offices

4. “Bottom 4” Module Position

“Socials” module

This module is created by JSN PageBuilder 3 Free Edition with List element.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.
Click on Edit FullScreen → Advanced tab → Module Class Suffix: footer-module-menu

Socials module

5. “Bottom 5” Module Position

“Connect” module

This module is created by JSN PageBuilder 3 Free Edition with List element.
You should check all of the tabs: General, Styling and Advance to review all of the customize for each element in this module.
Click on Edit FullScreen → Advanced tab → Module Class Suffix: footer-module-menu

Extra Pages
There are 9 extra pages in JSN Power: Quick Tour, About, Contact, Shop, Coming Soon, 404 Error. All these pages are built by
JSN Pagebuilder 3 FREE Edition. Settings for all the related elements can be seen in the PageBuilder 3 Documentation
(https://www.joomlashine.com/documentation/jsn-extensions/jsn-pagebuilder/jsn-pagebuilder3.html).

Quick Tour

“Quick Tour” page presentation

The Quick Tour page contains modules/article:
1. “Quicktour Slide” Module
2. “Our Subjects Quicktour” Module
3. “Quick Tour” Article
4. “Main Features” Module
5. “Joomla Default Styling!” Module

About

“About” page presentation

The About page contains modules/article:
1. “About Us Promo” Module
2. “We Are JSNPower” Module
3. “About Us” Article
4. “Count up numbers QT” Module
5. “Our Lovely Customers” Module

Contact

“Contact” page presentation

The Contact page contains modules/article:
1. “Gmap” Module
2. “Contact Us” Article

Shop

“Shop” page presentation

The Contact page contains:
1. Go to Main Menu → select J2Store, this module called J2Store → Products List View item.
2. “Categories” Module
3. “Cart” Module

Coming Soon

“Coming Soon” page presentation

To edit it, go to Extensions → Templates → Style → JSN Power - Coming Soon.

“Coming Soon” Style

To edit the content of Coming Soon page, go to Articles Manager → search for Coming Soon article.

404 Error

“404 Error” page presentation

To custom for this page, go to template setting page → Extras tab → Custom 404 → click on Enable Custom 404.

“404 Error” page configuration

After saving custom 404, you can see Destination Article is 404 Error (ID: 129), click on Edit Article to adjust content for this
page.

Colors Variations
JSN Power provides six major color variations for you to choose from. Each color variation covers not only the main
background, but also fills the drop-down menu, links, table’s header and others.
All available colors are described below.

Theme Blue

Theme Cyan

Theme Orange

Theme Red

Theme Pink

Theme Purple

To change the template color, you can go to template style list, switch style from default to another style.

Template Styles List

Here you can see eight styles of JSN Power. In each style color of the template, we included logo image, general color different
from other styles. The layout of them the same with style default, you can open each of them to check the setting and
customizations.
This template not only allow custom six colors, you can custom for your site multiple colors. Go to Template Setting Manager
→ Styles → General.

Template multiple color settings

Here you can change the Main Color, Sub Color, Default Button, Primary Button and Link Color.

Template Configuration
Now as you have learned how to customize the template. To fully understand the template's structure and hot features, please
navigate
to JSN Power Configuration Manual.
This website uses cookies to ensure you get the best
experience on our website. More information
(https://www.joomlashine.com/joomlashine/privacypolicy.html)
JSN POWER

CONFIGURATION MANUAL (HTTPS://WWW.JOOMLASHINE.COM/DOCUMENTATION/JSN-TEMPLATES/JSN-POWER/JSN-POWER-CONF
Got It!

