JSN BookStore Configuration Manual
Getting Started

The Sun Framework is automatically installed when you install JSN Template Gen.2 templates.
In case manual installation is needed, please download the plug-in from our Customer Area and install it as a normal Joomla
extension: Navigate to Extensions → Manage → Upload Packages → Select the Choose File button. Locate the downloaded ZIP
and click Upload & Install to begin the installation process.

System Requirements

System

Requirements

Joomla

Joomla 3.6+

Database:
MySQL 5.1 +
SQL Server 10.50.1600.1 +
PostgreSQL 8.3.18 +
Server
Web Server:
Apache 2.0 +
Microsoft IIS 7 +
Nginx 1.0

Firefox 4 +
Google Chrome 10 +
Browser

Opera 10 +
Safari 5 +
Microsoft Edge

Windows:
WAMPSERVER
XAMPP for Windows

Development Environment

Linux:
LAMP Bundle
XAMPP for Linux

Mac OS:
MAMP & MAMP PRO
XAMPP for Mac OS

License
JSN Sun Framework is FREE, and released under the GPLv2.0 license: (http://www.gnu.org/licenses/gpl-2.0.html) Everyone is
permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Images, flash files and cascading style sheets (css) files are released under a JoomlaShine.com Proprietary License. All
content and images shown on demos or sample data are for presentation purposes ONLY and ARE NOT INCLUDED with any
templates or extensions.

User & Product Verification
After installed JSN templates, you must go through the User & Product Verification section on the page layout.

User Verification
When you click on the Get Started, the User Verification modal will be show. Here, you need to input JoomlaShine account for
verification. After that, click on the Verify.

user-verification

Product Verification
After you completed User verification section, you can see Product Verification modal show on the display, you need to check
you information of the product you bought. Click on the Let's get started to install sample data.

product-verification

Installation
To build your website by JSN SunFramework, you need to install JSN Template Gen-2 which built on JSN SunFramework.
There are two ways to install JSN Template: install sample data via template package installation and install by quickstart
package.
This section will help you with steps to install JSN template - Template Installation and Quickstart Installation.

Template Package Installation
1. Download the template installation package
Log in JoomlaShine Customer Area (https://www.joomlashine.com/customer-area.html) to download the template package
that you have purchased. Make sure that you have downloaded the file marked with “Installation Package.”

Depending on your order, you should have a template installation file either called {jsn_ld_param key=template-shortname/}_2_Z.Z.Z_install.zip (Z.Z.Z is the template version).

2. Install the template package
This is a standard Joomla! Template installation file, which can be installed in Joomla! Administration as usual. Here are quick
instructions to remind you:
In Joomla! Administration, go to menu Extensions -> Extension Manager -> Install click Or browse for the file, select template
installation file or drag and drop template installation file.

Install the template package

Installation file will be uploaded to your server and installed in your Joomla. Once the process is completed, you will see the
following notification.

Install successfully

Now, the template is installed, but your layout and style need to be re-configured. You can build your own layout and set your
style from here. However, it will be more convenient if you choose to install our Sample Data.
Please see our instructions below for further details about sample data installation.

Sample Data Installation
NOTE:
Sample data will be installed for common Joomla components and for supported third-party extensions. Some
extensions are not included in the template package, so you need to download manually in the website of the thirdparty extensions. Therefore, if you need the sample data for the third-party extensions that come with your template,
make sure that you have installed them all before running sample data installation.
In some cases, the third-party extensions that you have installed are not matched with the ones that come with
sample data, the installation process will not be completed. Please check the log at the end of the installation step to
see the Version Requirement, then go to the extensions' websites and download them. After that, run the sample data
installation again.
Third - party extensions this template support: {jsn_ld_param key=extension-name /}
(https://www.joomlashine.com/documentation/jsn-templates/{jsn_ld_param key=template-short-name
/}/{jsn_ld_param key=theme-name /}-configuration-manual.html#third-party-extensions)
All JoomlaShine templates have the unique feature of installing sample data which makes your website look the same as on
the template demo website.
You can start the sample data installation process by clicking on Get Started button, which appears at the end of your template
installation and user verify step, or from the Data Menu Item on the top of JSN Template Gen-2 template style settings page.

Click Install sample data button on the sample data you want to install.

Option 1: Install everything including content, layout and style
YYour current contents will be erased. This option is suitable when you build a new website, and current contents are of no
importance to you.

1. On page JSN Template Gen-2 Sample Data Installation follow on-screen instruction to start the process.
Download sample data package of the demo website data such as: demo articles, demo menus, demo template settings,
etc.
Install free versions of JSN extensions: JSN ImageShow, JSN PowerAdmin, JSN PageBuilder 3 and JSN UniForm.
Install sample data: this step will check the template version before installing the sample data.

2. Click the “Start editing” button to Return to template settings page for further configuration.

In this window, the information of third-party extensions them are supported style in the template which need to be purchased
and installed manually. Click on Learn more or Download now to get more information.

Option 2: Install only layout and style
Your current contents will be untouched. This option is suitable when you want to migrate your existing site to JoomlaShine
templates.

Original data restoration
Before the sample data installation process, all original data of your website is automatically backed up into a backup file

located in /backup inside the joomla_root_folder/templates/JSN Template Gen-2_XXX/, where XXX is the template edition on
your server. Technically, this is the zip file, which contains a plain text file with SQL instructions that need to be executed on
your Joomla! Database.
Below are the instructions on how to do that by using software phpMyAdmin 3.2.1.
1. First, login to phpMyAdmin and select your Joomla! database on the left column

2. Next, select tab Import on the horizontal menu bar

3. Next, click button Browse.., then select the backup zip file and click button Go at the right corner of the page.

After script execution, you can get back to your website to check how the original data was restored.

Quickstart Installation
Quickstart package is a fully functional Joomla! package containing the CMS itself, the database, the selected template and all
extensions used in the template.
Once you install the quickstart successfully, you will have a complete website that looks exactly same as our demo, with all the
configurations and data that we used on the demo site in one place.
NOTE:
You can NOT install a Quickstart package in Joomla administration. Instead, you will need to upload it to the host, extract
all the files - then click on the URL and follow the instruction there to set up your package.
Commercial extensions are not included in a quickstart package, even if you have purchased them. After installing a
quickstart package, install these extensions and run sample data installation to get the full demo look for these
extensions.
In some cases, you will need to update your Joomla version after installing the quickstart package.

Preparation
A template quickstart package downloaded from Customer Area (https://www.joomlashine.com/customer-area.html).
A hosting Cpanel account or an FTP connection.
A MySQL database with a user that has full privileges over this database.

Step 1: Download the Quickstart package from Customer Area
Note that the Quickstart package often has a big file size than the normal installation package. So it will be helpful if you have
a good internet connection.

Step 2: Upload the quickstart to your web folder
There are two main options, depending on your hosting features.
Option 1: Upload via Cpanel
Log on your Cpanel → Go to the public_html folder → Upload the Quickstart zip package → Extract all the files in this folder.

Option 2: Using FTP to upload extracted files from the Quickstart package to your public_html web folder

Step 3: Open your web browser, type or paste your URL in the address bar to start the quickstart installation process
Fill in all the fields below as required. Once you have completed all the fields, click NEXT to proceed to the next step.

Step 4: Enter your database configuration information
On this page, please enter the correct database info that you created for this Joomla.

Once you have filled in all the info, click NEXT to continue.

If all the information is correct, the quickstart package will be installed.
Step 5: Finalize the installation process
The congratulation message will appear when the package is fully installed. On this screen, you will be prompted to remove
Joomla installation.
Click on Remove Installation folder to perform this action.
After that, you can either log on your backend to start working on the site by clicking on “Administrator” button, or check how
the website looks by clicking on “Site” button.

Third Party Extensions
As there are different extension providers in Joomla world, it is a real challenge for most of the template developers to ensure
that their template styles are fully compatible with extensions of other providers.
JoomlaShine team always try their best to ensure that all the templates created with JSN Sun Framework are compatible with
the most popular Joomla extensions.
Depending on the specific features of each template, we will have extended style support for other 3rd extensions.
Sample data will be installed for common Joomla components and for supported third-party extensions. Some
extensions are not included in the JSN installation template package, so you need to download manually in the website
of 3rd. Therefore, if you need the sample data for the 3rd party extensions that come with your template, make sure that
you have installed them all before running sample data installation.
In some cases, the 3rd extensions that you have installed are not matched with the ones that come with sample data, the
installation process will not be completed. Please check the log at the end of the installation step to see the Version
Requirement, then go to the extensions' websites and download them. After that, run the sample data installation again.

J2Store
{jsn_ld_param key=template-full-name /} supports J2Store extension to help you build an online store for your Joomla eCommerce website. With J2Store extension integrated, you can easily create beautiful pages such as Product Category,
Product Detail, and Shopping Cart.
J2Store Free version will be installed automatically when you install sample data. You can uncheck to install this

extension in the install sample data process.
J2Store Installation

If you want to install J2Store PRO version, click onhttps://www.j2store.org/ (https://www.j2store.org/) to download and
you need to install this extension before installing sample data.
Go to Extensions -> Manage -> Install -> Browse the zip package that you have downloaded to upload and install it.

If you want to have your products displayed from categories or from single items, control the display of product price,
sku, stock and the add to cart button, you need to install the Product Display Module
(https://www.j2store.org/extensions/modules/product-display-module.html) from J2Store website. The module is free.
Browse the zip package that you have downloaded to upload and install it.
Go to Components -> J2Store and you will see this dashboard. From here, you can start creating your own store, either by
adding products & categories or going back to the template manager to re-install the sample data package, which
contains sample products for J2Store.

Now you have the {jsn_ld_param key=template-full-name /} extended style for J2Store.

HikaShop
{jsn_ld_param key=template-full-name /} supports HikaShop and we also build extended style to make HikaShop look in style
with the template. Below is how HikaShop and {jsn_ld_param key=template-full-name /} combination looks like. HikaShop is a
native E-Commerce extension for all versios of Joomla. It is built for simplicity and flexibility. HikaShop also has a wide range
of marketing tools, but also powerful statistics displayable on your HikaShop dashboard to help you manage your store.
HikaShop work well with {jsn_ld_param key=template-full-name /}.
Attention! If you install {jsn_ld_param key=template-full-name /} manually, you will need to install HikaShop by yourself.
HikaShop is not included in the {jsn_ld_param key=template-full-name /} template package. You can download HikaShop for
free at https://extensions.joomla.org/extension/hikashop/ (https://extensions.joomla.org/extension/hikashop/)
To setting HikaShop on backend you go to: Components --> HikaShop --> System --> Configurationand setting for your website.
You need to go four in eight tabs: Main, Checkout, Display, Feature.

Setting on Main Tab

Setting on Checkout Tab

Setting on Display Tab

Setting on Feature Tab

If you install our Quickstart package, then HikaShop is already included and you don’t have to install it!

Layout

This section covers the basics of layout configuration in JSN Template Gen-2 and other templates powered by Sun
Framework.
For most non-coder users, controlling layout in Joomla is often a real struggle. In most cases, users will need to accept the
layout as designed and coded by the template provider. However, this is no longer an issue with the new Layout Builder in JSN
Sun Framework. With a self-explanatory user interface, this the Layout Manager provides endless possibilities to create and
customize your Joomla template layout without a single line of code.
Here are some great features in JSN Sun Framework’s Layout Builder:
Easy-to-build drag & drop process: Creating a template layout from scratch just by dragging & dropping items into your
layout, with incredible speed and performance.
Painless customization: Thanks to the intuitive user interface, you can easily customizing the existing layout.
Flexible module position creation: Never have to wonder which files and codes are needed to add a new module position
in your layout, as you can do this directly in the framework’s intuitive user interface.
Unlimited Undo & Redo: No worries if you have made a mistake while building or customizing a template layout, as you
can always use Undo feature to take a step back and recover what you had previously.
Powerful backup & restore: Your layout can be backup and restore with just one click.
Highly responsive: Fully responsive with Bootstrap 3 support. The layout builder also offers editing mode in tablet and
mobile devices.
Easy to learn: There is no learning curve. What you see in the layout builder is what you get on the front-end view.
To start with layout configuration, go to Extension → Template → JSN_template_default. The first tab you see will be the
Layout tab, where you can have the ultimate control of the template layout.

Layout Control
Overview
Sun Layout Builder is a very flexible and powerful tool which gives you the ability to build and customize the existing template
with the intuitive drag-and-drop interface.

The Layout Builder consists of three main areas:
1. Layout Items: list of items which you can drag & drop into the layout.
2. Layout: including the main layout and four off-canvas regions. There are areas where your template’s layout items are
positioned and built.
3. Setting Panel: all the settings related to layout items which are being configured.

Undo & Redo
Sun Layout Builder allows you to undo and redo the actions that you made. Simply hit Undo to switch back or Redo to go forth.
This tool will surely save you a huge amount of time and efforts. Worry-free if you accidentally make a mistake.

Save Layout
Sun Framework offers Ajax save button for each settings tab. Changes will be saved quickly without having to reload the
setting pages.

Save as Custom Layout
This option gives you the ability to save the current layout and use it later on.
To save the current layout as a custom one, just click on Save As Custom Layout button. After that, type the name of the
layout.

Load Custom Layout
This button enables you to load custom layout that you saved.

Building a Layout
Concepts
Sun Framework’s layout concepts:
1. Page: Overall settings for the layout.
2. Section: Section is a division of a page. A section is automatically created when you add a row to an empty area in the
layout. It contains one or more rows in which you can add layout items.
3. Row: Row is the component contained in the section. Same as section, a row is automatically created when you add a
layout item on the left of the page. A row contains one or more columns corresponds one or more layout items.
4. Column: Column is the component contained in the row. Each column corresponds to only one layout item.
5. Layout items: These are smallest pieces in the layout. Each item is made up of one column.

Drag & Drop

You can start building your own layout by drag & drop items on the left panel into the layout area. After that, you can adjust

their settings via the right panel.
If you drag a new item into a blank area of the layout, it will automatically create a row, a column and section wrapped
around this item.
If you drag a new item below an existing row, a new row which contains this new item will be created. These two rows
will be in the same section.
If you drag a new item below an existing item/row in a column, these two items will be wrapped in the same column.
You can drag an existing item in the layout to any position simply by clicking on the drag icon in the item and bringing it
to anywhere you want.
Note: This feature is only available in PRO templates powered by JSN Sun Framework.

Adjusting Column Width
To change a column width, simply move your mouse cursor on the dividing line between two columns and drag it left or right,
depending on how you want it to go.

Sun Framework utilizes Bootstrap 3, which means there will be 12 columns in the layout.

Layout Settings
Common Settings
Most of the items in Sun’s layout share the following settings
Hide
Clone
Delete
Custom classes: for custom styling
Responsive display: hide or display item in different viewports (applied for columns/items)

Page Settings

This panel is the first thing you see when opening the Layout tab. It contains general settings for the template page setting.
Settings

Description

Enable
responsive

Show desktop
switcher

Boxed layout

Turn on or off responsive layout mode. This feature is on by default.

Display an icon that allows you to switch from mobile view to desktop view.

Change from full-width layout to boxed layout. Upon selecting this option, you can set the width for your
layout.

Margin

Set margin values for the page.

Show “Go to

Display go-to-top button near the bottom of the website. Upon selecting this option, you can select

Top” button

proper icons for this button.

Show Branding
Link

Display "Template by JoomlaShine" in center of the bottom on the website. You can set HTML content
for branding by click on Set HTML button.
Note: This feature is only available in PRO templates powered by JSN Sun Framework.

Section Settings

A section is automatically created when you drag a Layout Item into a blank area in the layout.
Section settings will appear when you select any section in the layout. See the available settings for a section in the screenshot
below:
Settings

Description

Enable full width

Set full-width layout for a section.

Enable sticky

Set sticky mode for a section. This feature is often used for header section.

Margin

Set margin values for a section.

Padding

Set padding values for a section.

Row Settings

Row settings will appear when you select any row in the layout. See the available settings for a row in the screenshot below:
Settings

Description

Margin

Set margin values for a section

Padding

Set padding values for a section

Custom classes

Specific CSS classes for custom styling

Column Settings

Column settings will appear when you select any column in the layout. See the available settings for a column in the
screenshot below.
Settings

Description

Margin

Set margin values for a section

Padding

Set padding values for a section

CSS classes

Specific CSS classes for custom styling

Display in layouts

Set visibility of columns in each viewport: mobile, tablet, laptop, desktop

Off-canvas Section

This section give you the ability to place menus, modules and positions in a special Off-canvas sidebar, used for both desktop
and mobile view.
The Sun framework offers four Off-canvas sections, which are located on the top, right, bottom and left side of the layout.
To set up a Off-canvas section, you only need to click on one of the toggle buttons, which are available on each side of the
layout builder, depending on where you want the Off-canvas section to display on the front end.
Settings

Description

Width

The width of the Off-canvas section (Applied for left and right off-canvas only).

Height

The height of the Off-canvas section (Applied for top, bottom off-canvas only).

Padding

Set the padding value, including top, right, bottom and left padding

Toggle position

Set the position of the toggle button.

Custom classes

Add custom CSS classes for the Off-canvas section.

Responsive Layout

The responsive mode is enabled by default. If you don’t want to use Responsive Layout, go back to Page Settings and deselect
Enable Responsive.
You can adjust the width of each item in tablet and mobile, as well as their visibility in each viewport, by going to each viewport
and change its settings.
The responsive viewport of Sun Framework layout is similar to that of Bootstrap 3. For further information, please see it.
Note: This feature is only available in PRO templates powered by JSN Sun Framework.

Items Settings

Layout Items

When you open template setting layout, go to list of layout items on the left of this page. There are eight layout items show on
the main layout: Logo, Menu, Module Position, Module, Main Body, Social Icons, Custom HTML, Flexible Space.
Now, let’s go to each item:

Logo Item

“Logo” item settings

After drag logo item to the layout, click on on logo item, go to Logo Setting Panel on the right of the page to select a logo image
for desktop and mobile logo via Media Selector and add your own Logo Alt. Text, Logo Link.

Menu Item

“Menu” item settings

This item allows you to show on visitor area the menu created from Joomla Menu Manager before.
Settings

Description

Name

Change the name of “Menu” item.

Menu

Select the menu you want to assign to the “Menu” item.

Base Item

Select a menu item to always be used as the base for the menu display.

Start
Level

End Level

Show

Submenu
Effect

Mobile
Target

Level to start rendering the menu at.

Level to stop rendering the menu at.

To show icon, menu description and sub-menu created on menu manager before. You can select one of three
option: Show Icon, Show Description, Show Sub-menu.

You can choose one of three options: None, Fading, Slide for submenu.

Display your menu as off-canvas menu in mobile view.

Module Position Item

“Module Position” item settings

With one module position, you can assign one or more modules to this item. First of all, you need to drag a module position
item to the layout and review some option:

Setting

Description

Name

Change the name of “Module Positions” item.

Module Position

View Module

Create New
Position

Select one of the available module positions. By default is “banner”, you should create other position
before select.

Click on this button you can see the modules is assigned for this position before.

Create a new position.

Module Item

“Module” item settings

Similar to the function of the “Module Position” item, you can assign module created before for this item, but you just assign
only one module for a module item by selecting module from Module selector. After clicking on the “select” icon you can find
your module faster by smart search tool.

Module Selector

Main Body Item
This item allows to show article/feature articles. You just drag only one item for one page. If your page has this item before
you select item to drag to the page, you will see a notification Layout already has item “Main Body”.

“Main Body” item settings

Show On Front Page: Turn on or turn off the mode to show or hide the main body on the frontend. This option only effect on
the menu of the homepage.

Social Icons Item

“Social Icons” item settings

If you want to put your site some social icons, simply drag “Social Icons” item to the page and make some quick settings:

Setting

Description

Name

Change the name of the “Social Icons” item.

Icons

Select the social icons you want to presentation by click on Add social icon.

Icon Color

Select the color for the icons.

Icon Size

Select the size for the icons.

Link Target

Select how the links of the social icons will be opened.

To add more social icons, click on Add Social Icon button → select a Social Network. Here you can the social link, click on the
icon image → Social Profile Link to update the social link.

“Social Icons” link

Social Icons supported are: Facebook, Twitter, Pinterest, Youtube, Google+, Instagram, Linkedin, Dribble, Behance, Flickr, Skype,
VK.

Custom HTML

“Custom HTML” item settings

This item allows you to put your HTML content, you just need to drag this item to the page and click on Set HTML content
button then type your HTML content there.

Custom HTML window

Flexible Space
Flexible Space allows you to add an empty space between items in the layout. This item doesn't have any special function but
merely a styling tool. Just drag the item to the page.

“Flexible Space” item settings

Styles
Overview
The built-in Styles Manager in JSN Sun Framework provides various options for configuring main stylistic aspects, from
typography, background to text and link color, in almost all the elements of your website.

Flexible Styles Management Through A Logical Style Hierarchy
The Styles Manager includes four comprehensive levels of styles:
General styles: Creating a master style for all layout elements. This section can be understood as the parental style for
your website.
Section styles: Controlling style of a section in your layout. Section can be seen as a group of rows which are parts of a
content block, for example: “Header” section, “Footer” section, etc. You can either create a custom style for each of them,
i.e. using a different background & text color. Otherwise, their the style attributes will be inherited from that in General
styles level.
Module styles: Controlling styles for modules on your site.
Menu styles: Defining styles for your menu.

Smart Color Management With Main And Sub Color
While allowing a great level of flexibility for configuration, JSN Sun Framework also provides a feature for you to manage your
main and sub color. It helps you to ensure the consistency in the use of colors across all the sections and elements of your site.

Powerful Typography
All of the templates powered by JSN Sun Framework come with the same wide variety of fonts to choose from. In any layout
element with typography settings, you will see three categories of fonts.
Standard fonts: Common/system desktop fonts which are “web safe” and widely available.
Google fonts: A large collection of 800+ beautiful and free web fonts hosted and served up by Google. We have also built
a user-friendly Google font selector, which gives you the option to find and filter Google fonts quickly by categories (serif,
slab, sans-serif, handwritten and monospaced styles) or subsets.
Custom fonts: This option enables you to upload your web fonts, which are usually commercial fonts related to your
business/brand.
You can select font types in the Heading and Content setting panel, as the image below:

Font tpye configuration

NOTE: This feature is only available in PRO templates powered by JSN Sun Framework.

General

General Page Style
This area gives you the ability to edit overall styles for both page outer and page inner.
Page Outer

If boxed layout is disabled, only settings for page outer style will be displayed:

General Page Style

If boxed layout is enabled, settings for both page outer and page inner style will be displayed:

Boxed layout configuration

Settings

Description

Background color

Background color of the page outer.

Background image

Background image of the page outer.

Background image settings

Settings when background image is used.

Page Inner

These settings are visible ONLY when boxed layout is enabled.

Page Inner configuration

Settings

Description

Background color

Background color of the page inner.

Border

Page border values. Visible only when boxed layout is enabled.

Boxed shadow

Used when boxed layout is enable

General Color Style
To set up the style color for main and sub in the template, click on Main Color and Sub Color in the preview panel on the left
side and change their settings on the right panel.

General Color Style

General Heading Style
To set up the style for all the headings in the template, click on any heading in the preview panel on the left side and change
their settings on the right panel.

General Heading Style

General Content Style

To set up the style for content text, click on the paragraph text area under the heading in the preview panel on the left side and
change their settings on the right panel.

General Content Style

General Button Style
To set up the style for buttons, including Default Button and Primary Button, click on each of these buttons on the preview
panel and change its settings on the right panel.

General Button Style

General Link Style
To set up the style for links, click on the link in the preview panel on the left side and change its settings on the right panel.

General Link Style

Section

Go to the Styles → Section, you will see the same section names and many styling options for each of them. For example, the
style for section "Top" in layout tab will also be under section "Top" in Styles tab. This makes it easy for you to locate where the
customization can take place.

Section Container Style
You can change the style of each section’s container simply by clicking on the area around the border of the section that you
want to have custom style, and change its settings on the right panel.

Section container style

Section Heading Style
By default, Section Headings Style will be inherited from General style. If you want to have different styles for section Heading,
click on Use Custom Settings to activate custom style settings.

Section heading style

Section Content Style
Section Content Style will be inherited from General style. If you want to have different style for section Content, click on Use
Custom Settings to activate custom content style settings.

Section content style

Section Button Style

By default, Section Button Style will be inherited from General style. If you want to have the different style of section Button,
click on Use Custom Settings to activate custom button style settings.

Section button style

Section Link Style
By default, Section Link Style will be inherited from General style. If you want to have different style for section link, click on
Use Custom Settings to activate custom link style settings.

Section link style

Module

First, go to tab Styles → Module. From here you will see some module styles provided by the template.
The Sun Framework comes with 04 to 06 highly flexible module styles, and you can customize each of them in the same way
with Section.

Module Container Style
Similar to Module Container Style, you can change the style of each module container simply by clicking on the module that
you want to have custom style, and change its settings on the right panel.

Module container style

Module Title Style
To change the style of a module’s title, click on the title of the module style that you want to customize in order to see its
available settings.

Module title style

Module Content Style
To change the style of a module’s content, click on the content area of the module style that you want to customize in order to
see its available settings.

Module content style

Module Button Style
By default, the button style of the module is inherited from the General settings.
To enable custom style for module settings, select “Use custom setting” to open custom style options and make changes as
you want.

Module button style

Module Link Style
To change the style of a module’s hyperlink, click on link in the module style that you want to customize in order to see its
settings.

Module link style

To apply a style to a module:
Open a module in Joomla Module Manager.
Go to Advanced tab:
1. Select a style from the list in the dropdown.
2. Add Awesome Font code in Header Class to have icons for your module heading.

Module styles configuration

More Font Awesome icons can be found here: http://fontawesome.io/icons/ (http://fontawesome.io/icons/).

Menu

To change a menu style, go to Menu tab and change their style settings in the right panel.
To change a parental menu style, click on any parental menu item to open its settings and customize it.

Root menu style

To change a sub-menu item style, click on the submenu in the preview panel to open the settings.

Dropdown menu style

Mega Menu

Overview
There is an increasing need for mega menu, as it improves the navigability and aesthetics of modern websites. Understanding
that mega menu is a must-have item, JSN Sun Framework has integrated an innovative Mega Menu Builder in its core since its
birth. This tool gives you the ability to build a complex Mega Menu in the most user-friendly and versatile manner.

The following are some key features of the Megamenu Builder in JSN Sun Framework:
Easy to use: Megamenu can be built with simple drag & drop, similar to the way you handle the Layout Manager in JSN
Sun Framework.
Painless customization: Basically, what you see is what you get. Everything in the Megamenu Builder can be edit with
some simple clicks.
Multi-column layout support: Since it’s based on Bootstrap 3, you can create up to 12 columns in the Megamenu Builder.
Unlimited content type support: The ability to display all kinds of content types in menu item including text, images,
videos, module, etc.
Mobile friendly: Megamenu created with JSN Sun Framework is responsive, and thus displayed nicely on any mobile
devices.
NOTE: This feature is only available in PRO templates powered by JSN Sun Framework.

Building a Mega Menu

Building a Mega Menu

Megamenu in templates powered by Sun Framework can be built with the following steps:
Click Mega Menu on top bar of the template framework.
Select the menu & language of the menu that you want to config.
Drag menu item into the main menu panel. Settings for each of these items will be available on the right panel.
Config menu container, row and column in the same way you do with the Layout.
Let’s start with a mega menu like the image below:

Step 1: Create menu content
First of all, you need login to your Joomla administrator area and install JSN Template. Go to Menus → Manage → Add new
menu, here you can create a new menu and menu items to appear in the menu.
For example with the image on the top, we need to create a menu is SubMenu, and then create some menu items in the
SubMenu.

Next, go to module manager to create a menu module. In this section, we create a module has some information:
Module Title: Mega Menu
Select Menu: SubMenu
Start Level: 1
End Level: All
Show Sub-menu Items: No
Show Title: No

Step 2: Setup Mega Menu

Now, you can design for your megamenu more beautiful. Go to Extensions → Templates → JSN Template Gen-2 → Mega
Menu. Here, you need to select a menu to design.
After select a menu, click on a menu item to design mega menu there. With example on the top, you need to drag and drop two
custom html items, a module and image item. And then you can change the position of the items.

Custom HTML item: after selected custom HTML item, click on the Set HTML Content button and add your HTML content
there.

Module item: you need to select the module menu type was created before.

Image item: you need to select or add a path of the image to show in the visitor area.

System

Despite its geeky and unattractive name, this System Configuration offers some down-to-earth but amazing features that most
web owners need:
Adding website favicon icon: Instead of using FTP client to upload your favicon icon to the template folder, you can go to
this section and upload your icon from here.
Adding custom CSS and JS: If it is important for you to have your own custom CSS and JS, you can upload them to your
template folder and specify their locations here.
Improving website’s speed: Accelerating your site’s loading speed with built-in CSS and JS compression tool.
Adding external tracking codes: The framework allows you to flexibly add external codes of third-party platforms before and
after head and body tag. You can utilize this feature to add tracking codes required by Google Analytics, Google Tag Manager,
or those of other tracking services.

Assets Compression

With Sun Framework, we put great effort into optimizing our template performance with multiple techniques like image sprites
application, clean html code output and now one new step – CSS/JS Compression.
It helps combine all continuous CSS/JS files into compressed files and deliver it in GZIP compressed state to browser. The
order of CSS/JS files is the same before and after the compression. This feature significantly reduces http request number to
server as well as overall loading size, which results in significant performance boost.
Note: This feature is only available in PRO templates powered by JSN Sun Framework.
You can configure the compression settings in the tab Advanced → section Assets Compression:
Compress CSS/JS: Allows you to select to compress both CSS and JS, Only CSS, Only JS or nothing.
Max File Size: Defines the maximum size a compressed file should be.
Exclude from compression: Set a list of files you don’t want to be compare.
Cache Directory: Specify the directory for storing compressed CSS/JS file.

Custom Code
You can define where to insert the Analytics Code code by template parameter Custom Code.

Custom Files
For all customization purposes, Sun framework allows you to load multiple CSS/JS files you customized without altering the
template core files.
Just put custom CSS/JS files to template's CSS/JS folder and define them in template parameter Custom CSS File(s) and
Custom JS File(s); each file name at a line.

NOTE: If you enable CSS/JS Compression feature, all custom CSS files will be compressed as well.

Extras

In this section, you can settings for:
Cookie Consent
Social Share
Commenting
Custom 404

This section is only available in PRO templates powered by JSN Sun Framework.

Cookie Consent
A Cookie Consent is a quick way to ask your visitors about their cookie permissions, making sure that your website is
compliant with EU Cookie Consent Policy. When GDPR is finally enforced from 25 May 2018, plenty of websites have made a
new change: to add a cookie consent on the front-end as a message to ask for users' agreements.
To enable Cookies Consent, go to Extras → Cookie Consent → Select Enable Cookie Consent to config its layout styles and
contents.

Settings

Enable Cookie
Consent

Description

Choose whether to use Cookie Consent.

There are 2 styles of Cookie Consent to choose from: Light and Dark

Style

Select position of initial consent slide-down notification

Placement

Cookie Consent content: You can use either a simple text message for Cookie Consent, or use an
article to display the message.

Message

Policy Text

The text link to the cookie policy for example is More Information or Read More (requires Your
Cookie Policy Link to be set)

Policy link

The url of the Cookie Policy that links to the Cookie Policy.

Accept Button Text

The label of the accept button

Define script that will be inserted to the page output if "accept" cookies found. All the scripts here
will be activated if users agree to share their data, or they hit the Got It button.

Accept Script

Social Share
This feature allow you show some social channel, the reader can share the articles to socials.

Enable Social Share
To setting Social Share for articles, go to Extras → Social Share. By default, the display shows a white page, you need to click
on Enable Social Share.

Social Share configuration

Social buttons: Facebook, Google+, LinkedIn, Twitter, Pinterest.
Buttons Position: Top left, Top Center, Top Right, Buttom left, Buttom center, Buttom right.
Category: Select article categories.

Social Share presentation

Commenting
This feature allows you to create a comment field below the article. You can configure commenting type: Disqus, Facebook,
Google+ or IntenseDebate.

Enable Commenting
To setting Commenting for articles, go to template page setting → Extras → Commenting. By default, the display shows a
white page, you need to click on Enable Commenting.

Commenting configuration

Commenting: You can select one of types: Disqus, Facebook, Google+, IntenseDebate.
Show text: click on the show text to show title of list comment, you can hide this text by unclick on this box or change the
content of the text box.

Category: Select article categories.
Some commenting type Disqus, Facebook and IntenseDebate you need to typing the contents to request field.

Disqus

You can go to Disqus website (https://disqus.com/profile/signup/) to create a disqus account for Joomla website. After that,
type the Subdomain to the Disqus Subdomain box.

Commenting Disqus type presentation

Facebook

Type your Facebook App ID. If you don't have any Facebook account, visit https://developers.facebook.com to create one.

Commenting Facebook type presentation

Google+

This type, just select commenting type.

IntenseDebate

Before you select this type, you need to create a IntenseDebate Site Account and input it into the IntenseDebate Site Account
box on the page layout. Save Commenting to finish.
You can go to IntenseDebate website (https://intensedebate.com/) to create a IntenseDebate account for your site.

Custom 404
To custom for this page, go to template setting page → Extras tab → Custom 404 → click on Enable Custom 404.

“404” page configuration

After saving custom 404, you can see Destination Article is an article name, click on Edit Article to adjust content for this page.

Assignment

After assigning the menu item for your template, in the Assignment tab, all of the menus and menu items you created before
will be show.

Menus and menu items on the assignment

This feature allows you to select the layout style for each page of each menu item. You can select any menu items (pages) to a
layout. By default of all templates, the styles’s default was assigned for all page.
If you want to assign a layout for some pages, click on the select box of each menu item.

Select menu items

Now, you can see the number of the pages which are assigned to a layout when you are back to the outside of layout display.

Pages was assigned

Finally, go to the frontend to check the pages.

Template Style Settings Import/Export
The Import/Export function enables you to export and import your template style settings. You can export all the settings that
you configured to save as a backup file or reuse it somewhere.

Export
On the template page setting click on the Data → Maintenance.

Then you need to click on the Export button to export your template settings.

After that, a backup file will be automatically downloaded. Now you can import your template configuration to other sites using
JSN Sun Framework.

Import
After you have a backup file from the export process, follow the first step in the Export section, and then click on the Import
button to import a backup file.

Now, you need to select a backup file which was exported before. Go to your folder which you saved the backup file, select a
file and click on the Open button and wait for restoring.

When the import process completes, the display will show a successful message as below.

Menu Variations
Side menu

Side menu presentation

Side Menu is a unique vertical menu with slide-out panels. This menu is extremely efficient when you have complex navigation
with a lot of menu items.

To set up Side Menu, select the menu module you want to use to Module tab → Select Menu parameter, and then go to
Advanced tab → Menu Class Suffix parameter → type menu-sidemenu class as the image below:

Side menu configuration

Tree menu

Tree menu presentation

To set up Tree Menu, select the menu module you want to use to Module tab → Select Menu parameter, and then go to
Advanced tab → Menu Class Suffix parameter → type menu-treemenu class as the image as below:

Tree menu configuration

Div Menu
Div Menu is a unique horizontal menu. This menu is extremely efficient when you have menus not include sub-menu.
With some JSN Templates, we added Div Menu, to set up Div Menu, select the menu module you want to use to Module tab →
Select Menu parameter, select your menu you want to make Div Menu. Next, go to Advanced tab → Menu Class Suffix to add
class: “ menu-divmenu” the same as the image below:

“Div Menu” configuration

Menu Icons

You can attach any of many icons to menu items to make them more appealing.

Setting main menu icons

To set up icons, you need to go to Sun framework Options tab settings and select symbol combination on Link Icon.
Next, go to Tempate Layout Settings area --> click on Menu --> Show Icon.

Setting main menu icons

Menu Rick text
You can add descriptive text to menu items to make them much clearer.

Setting main menu rich text

To set up descriptive text, you need to go to Sun framework Options tab settings and add descriptive text toLink Description.
Next, go to Tempate Layout Settings area --> click on Menu --> Show Description.

Setting main menu rich text

Typography
With strong support from Bootstrap 3, JSN Template Gen-2 was created with a strong focus on typography and we believe it
contains the most comprehensive content presentation capability. Headings, Images, Paragraph, List, Button & Links, Alert,
Tables styles. Here we introduce some featured content elements. However, you can create more elements with Bootstrap 3
(https://getbootstrap.com/docs/3.3/).
Let’s take a look some featured elements of JSN Template Gen-2.

Heading

Heading Styles presentation

To apply them you just need to wrap your heading text in regular heading tags like: <h1>…</h1>, <h2>…</h2>, <h3>…</h3>, etc.

Image

Image Styles presentation

Image Styles

Class

Image

None

Image with border

class="border-image"

Image with caption

<figure><img src="/....." alt="..." />
<figcaption>Image with caption</figcaption>
</figure>

Image with border and caption

<figure><img class="border-image" src="/...." alt="...." />
<figcaption>Image with border and caption</figcaption>
</figure>

Paragraph

Paragraph Styles presentation

Paragraph Styles

Class/tag

Normal Paragraph

class="text-left"

Blockquotes

<blockquote>....</blockquote>

Align Left/ Dropcap

class="drop-cap"

Highlighted content

<span class="bg-warning">...</span>

List

List Styles presentation

List Styles

Class/tag

Unordered list

<ul class="list"><li>....</li></ul>

Ordered list

<ol class="number-list"><li>....</li></ol>

Plain list

<ul class="plain-space"><li>...</li></ul>

Button & Link

Button & Link Styles presentation

Button Link Style
Usage:
<a class="btn btn-xxx" href="#">Name button</a>
Where xxx is the button name.
Example:
<a class="btn btn-danger" href="#">Danger button</a>

Button Icon Link Style
Usage:
<a class="btn btn-xxx" href="#"><i class="fa fa-yyy"></i>Name button</a>
Where xxx is the button name, yyy is icon name.
Example:
<a class="btn btn-default" href="#"><i class="fa fa-star"></i>Default button</a>

Alert

Alert Styles presentation

Alert Styles

Success

Class/tag

class="alert alert-success"

Danger

class="alert alert-danger"

Information

class="alert alert-info"

Warning

class="alert alert-warning"

Table Styles

Table Styles presentation

Table styles

Plain Rows table style

Class/tag

table class="table table-bordered" border="0" width="100%"
thead class="thead-inverse"

Grey Stripes Table Style

table class="table table-bordered table-striped" border="0" width="100%"

Color Stripes Table Style

table class="table table-bordered table-striped style-colorstripes" border="0" width="100%"

Table with Link Header

table class="table table-bordered table-striped" border="0" width="100%"

Additional Content Types
This feature allows you to add new content types to an article without HTML code. Sun Framework provides 06 new content
types: Standard, Audio, Gallery, Link, Quote, and Video.

Content Types

Standard Type
Standard type works in the same way with the image tag.
To use Standard Type content, go to an article → Sun Framework options → Select Standard → click on the Featured Image box
to select an image for articles.

Standar Types

If you want to change your image, click on the browse icon to select a new one. Click on the remove Icon, if you want to remove
the Featured Image.

Audio Type
In Sun Framework option → Select Audio type → add your Audio Embed Code.

Audio Types

To get Audio Embed Code on the Soundcloud, you need go to Soundcloud to click on the Share button → Embed → Copy
code in the text box.
In Sun Framework option → Select Audio type → add your Audio Embed Code.

Get Audio Embed Code

When you finished, don't forget to click on the Save & Close button.

Gallery Type
Select Gallery from Content type, and then click on the Select Image to insert images into the gallery.

Gallery Type

Link Type

Link Type

Here you need to select Link in the Content Type option and fill in the Link Title and Link URL.

Quote
After selecting Quote type, enter Quote Text and Quote Author in the text box.

Quote Type

Video
Just paste your Video URL to the text box.

Video Type

Show Menu Metadata
This feature allows you to show the content of metadata in menu items. You can show Page Heading, Link attribute, Link
image, Page Subheading just use a syntax structure.
{jsnmenuitem_meta content="attribute"/}

Show Page Heading
{jsnmenuitem_meta content="menu_item_title"}

Menu Title

Show Page Subheading
{jsnmenuitem_meta content="link_description"}

Menu Description

Link Image
{jsnmenuitem_meta content="link_image"}

Link Image

Link Attribute
{jsnmenuitem_meta content="link_title_attribute"}

Link Image

For example to create a module show Page Heading and Page Subheading of menus as the image below:

Menu Contact

You need to create an article or module. This example starts with a custom module.

Custom Module

After click Save & Close button, frontend will show the same image below:

Menu metadate show on the frontend

Product Update
JSN Template Update Notification
Open a JSN template → If the template is outdated, you will see a notification on the top bar like Update available for JSN
XXX version → Click on the Update button on the top right.

Upon clicking the Update button, you will see some important information and the link to check the changelog.

User Account
This is a feature of JSN Sun Framework, it allows the customer refresh license and switch account.

Refresh License
When should the client refresh the license?
If the customer is using only one account for the free license of a template package, they upgrade the template from free to
trial or PRO license with the same account.

How to refresh license?
In the layout page setting, click on Settings item on the top menu → click on User Account.

“Refresh license”

Here you just need to click on Refresh license button and wait a few seconds to license is refreshed.

Unlink Account
When should the user unlink account?
When the customers are using a JoomlaShine account on the template and want to change to another JoomlaShine account
with other license or the same license.

How to unlink account?
In the layout page setting, click on Settings item on the top menu → click on User Account.

“Unlink account”

Click on Unlink account button to input your new account.

“User verification”

Input another JoomlaShine account to the parameter, click on Verify button to check the product verification.

“Produc verification”

Click on Let's get started button to go to the next step.

Privacy Settings
Once you're done to check product verification step, you can see Privacy pop-up.

“Privacy settings”

When you install something new on Joomla! website, you may wonder whether it affects the whole data or not. That’s why
JoomlaShine team finds it necessary to clarify this concern on the new update of JSN Sun Framework. You are enabled to
decide to share your experience with us when using any JSN template on the Privacy feature. This option is meant to respect
your privacy and make you understand how we collect, use, and share data from you.
Click on I agree, improve my experience button or I decline button to finish.
You can open this feature by following other steps:
Go to the Settings tab in the top right corner --> Choose Privacy.
Tick or untick the I agree, improve my experience option, and hit the Save Settings button to make an agreement.

“Privacy settings”

Tips & Tricks
Custom CSS in Sun Framework
Most of the pages on JSN templates are designed with beautiful styles, and JSN Sun Framework provides a wide variety of
styling options. However, you may have some unique styles that the standard settings of JSN Sun Framework cannot offer. In
this case, you will need to use custom CSS. You can easily add custom CSS in JSN Sun Framework as below:

Step 1: Open the file custom CSS file in the template folder
Login to your administrator area → Extensions → Templates → Templates → JSN Template Gen-2 → css → custom.

Go to custom.css file

Now, let’s add your CSS code there.

Step 2: Declare your custom CSS file
The final step is declare custom.css file. Go to: Extensions → Templates → JSN Template Gen-2 - Default → System. In the text
box Custom CSS File(s) you must type the path of custom.css file.

Declare the custom css file

Your own CSS file?
You can create your custom CSS file and name it the way you prefer.
Via FTP to access to root_folder/templates/template_short_name/css/custom, here you can create your css file. After that, go
to System tab in JSN Sun Framework to declare your custom CSS file as described above.

Favicon
Favicon is a small icon positioned on the left of the address bar of your browser. By default, Joomla! has an icon as shown on
the screenshot below.

Favicon presentation

Here are instructions on how to do that:

Step 1: Create Favicon File
Favicon is a regular 16px * 16px icon file with exact name favicon.ico. In most cases, favicon is the sized-down version of the
company logo saved in the icon format. In some cases, the logo is too specific and favicon needs to be built from scratch.
You can use some professional icon editor software like Axialis IconWorkshop (http://www.axialis.com/)and Iconcool Editor

(http://www.iconcool.com/icon-editor.htm)or to use online favicon generators. (http://www.google.com/search?
q=favicon%2Bgenerator&amp;ie=utf-8&amp;oe=utf-8&amp;aq=t&amp;rls=org.mozilla%3AenGB%3Aofficial&amp;client=firefox-a)The first method gives you better quality, but takes more effort. The second method is
easier, but the quality is not the best.

Step 2: Upload Favicon File
After you have got the favicon file, it is time to upload it to your server. You will need to upload the icon file to the template
folder via FTP.
Let’s go to joomla_root_folder/images to create a new folder and upload the favicon file there.

Upload favicon file

Step 3: Change the favicon in the template settings
Go to Extensions → Templates → Styles → Template_Full_Name - Default → System tab → Icons → choose browse file in the
Favicon parameter, here you need to select favicon.ico updated before, and then click on Save System to finish.

Favicon selection

Media selector is opened. Now, select your uploaded favicon file to change.

Select favicon file via media selector

Go To Top
To turn on/off the Go To Top button, click on the layout of the entire page → Show “Go To Top” button.

“Go To Top” configuration

Template Branding
When you install sample data, the content "Template by JoomlaShine" will be show on the bottom of your website.
NOTE: This feature is only available in PRO templates powered by JSN Sun Framework.

JoomlaShine Branding

To disable or change the content:
Go to Extensions → Templates → Styles → JSN Template Gen-2 - Default → Layout tab select all page, the Show Branding
Link option will show on the setting panel.
Untick the Show Branding option to disable branding link.
If you enable to show branding, you can change the content shown on the frontend by clicking on Set HTML content.

Branding setting

